Ticket #263 (closed problem: fixed)

Opened 4 months ago

Last modified 4 months ago

[SOLVED] Problem with vso_jsoc_fetch.cgi

Reported by: niles Owned by: niles
Priority: highest Milestone:
Component: Undefined Version:
Severity: blocker Keywords:
Cc:

Description

A cpanm update to install a perl module caused vso_jsoc_fetch.cgi to break in a subtle, but very significant way at NSO. This broke data downloads not only at NSO, but also at SDAC, because SDAC was set up to attempt downloads from NSO before the JSOC.

Worse, the change in the JSON output by vso_jsoc_fetch.cgi was reasonably subtle. In part, the JSON should have looked, in part, like this :

"susize" : "10284610"

But instead it looked like this :

"susize" : 10284610

The JMD was unable to parse the JSON. This caused a lot of confusion. It initially appeared that both SDAC and NSO machines had somehow simultaneously been affected (not so, it was only a bug in the NSO vso_jsoc_fetch.cgi web page) and it initially appeared as a JMD error (not so, the JMD was simply nable to parse the JSON).

The end result, however,was reasonably positive. A fix is in place for the vso_json_fetch.cgi web page, and a more definitive fix can probably be done when setting up a new NetDRMS machine. The JMD will now print better error messages if it cannot parse the JSON. And the SDAC's JMD configuration file was tidied up significantly.

Still, about a week was lost to this bug.

The issue is discussed in more detail at a technical note that can be got at from the root of this document :

infrequently asked questions -> technical notes -> Various notes that may be useful -> Encoding JSON using perl

Change History

comment:1 Changed 4 months ago by niles

  • Status changed from new to closed
  • Resolution set to fixed

comment:2 Changed 4 months ago by niles

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:3 Changed 4 months ago by niles

  • Owner changed from joe to niles
  • Status changed from reopened to assigned

comment:4 Changed 4 months ago by niles

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.