Ticket #315 (closed problem: fixed)

Opened 2 weeks ago

Last modified 9 days ago

KSO data not searchable from IDL commandline.

Reported by: alisdair Owned by:
Priority: high Milestone:
Component: IDLClient Version: 1.4
Severity: major Keywords:
Cc:

Description

A search for KSO data works with the web interface but for some reason is returning no match found in the registry when I try to do the search on the IDL command line.

IDL> a = vso_search('2018-05-03T00:00:00','2018-05-04T00:00:00', instrument='KHPI')                   
Records Returned :  : /
     : VSO-V300 Empty Request - No match found in VSO Registry for search critera
% VSO_SEARCH: no matching records found
IDL>

Attachments

Screen Shot 2018-06-05 at 5.26.44 PM.png (261.3 KB) - added by alisdair 2 weeks ago.
Example of VSO Web query for KSO data

Change History

Changed 2 weeks ago by alisdair

Example of VSO Web query for KSO data

comment:1 Changed 2 weeks ago by alisdair

Have found the issue. In latest vso_server.pro

    proxies = [ $
         'http://sdo5.nascom.nasa.gov/cgi-bin/vsoi_tabdelim' $
        ,'http://kurasuta.cfa.harvard.edu/cgi-bin/VSO/vsoi_tabdelim' $ (backup DNS name)
        ,'http://sdac.virtualsolar.org/cgi-bin/vsoi_tabdelim' $
        ,'http://vso.nascom.nasa.gov/cgi-bin/vsoi_tabdelim' $ (backup DNS name)
     ]
    vso_env=getenv('VSO_SERVER')
    if is_string(vso_env) then proxies = [vso_env, proxies ]

If in my environment I define VSO_SERVER to be say http://sdac.virtualsolar.org/cgi-bin/vsoi_tabdelim or even http://vso.nso.edu/cgi-bin/vso/vsoi_tabdelim then the query returns results as expected. The issue is with the definition of VSO_SERVER being http://sdo5.nascom.nasa.gov/cgi-bin/vsoi_tabdelim. I'm guessing there is a registry file on sdo5 that was not updated?

comment:2 Changed 9 days ago by ed

The registry file kso.xml was missing on sdo5. It's been added now and a test of SSW/IDL returns data for 12/17/17 inst=khpi

Records Returned : KSO : 1/1 {

"TIME": {

"START": "2017--1-02T17:00:07", "_END": "2017--1-02T17:00:07"

}, "EXTENT": {

"TYPE": "FULLDISK", "WIDTH": 0.0000000, "LENGTH": 0.0000000, "X": 0.0000000, "Y": 0.0000000

}, "WAVE": {

"MIN": 6562.9302, "MAX": 6563.6299, "TYPE": "Narrow", "UNIT": "Angstrom"

}, "DETECTOR": "", "INSTRUMENT": "KHPI", "SOURCE": "Kanzelhoehe Solar Observatory", "PROVIDER": "KSO", "INFO": "", "PHYSOBS": "Intensity", "FILEID": "http://cesar.kso.ac.at/halpha3a/2017/20171217/processed/kanz_halph_fi_20171217_074432.fts.gz", "SIZE": 5043240.0, "EXPTIME": 0.0000000, "DARK": 0, "ECLIPSE": 0, "PERCENTD": 0.0000000, "URL": "", "GETINFO": ""

} IDL>

comment:3 Changed 9 days ago by ed

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.